/    Sign up×
Community /Pin to ProfileBookmark

Text input rendering in IE 6.

Hi! I’m new here, and maybe this has been asked before, but I could not find it by searching.

I have composed web pages with forms using fields like:

<input name=”name” type=”text” class=”text” size=”20″ maxlength=”20″>
<input name=”phone” type=”text” class=”text” size=”20″ maxlength=”20″>
<input name=”email” type=”text” class=”text” size=”60″ maxlength=”60″>

etc.

When I view the page in IE (version 6.0.2900) SOME of the input fields have a yellow background – but OTHERS just have a plain white background.

This baffles me, since the markup is the same for all of them.

In the HTML source code, these <input> fields are listed one after the other with nothing in between them: that is, all of these fields are sourced exactly the same.

This effect is not random, because the same elements come up with a yellow/respectively white/ background every time I view that particular page.

A minor edit to the source (like changing the “size” value of an <input> field) sometimes changes the result on rendering – usually the yellow disappears and a text input background “mysteriously” washes out to white.

In Netscape, the backgrounds are all just white.

The problem is, having some of them yellow, and others white, looks funny and it seems like there is something wrong with the page – but the form works fine and everything else is normal…

Can anyone shed any light on this weirdness? Thanks.

to post a comment
HTML

5 Comments(s)

Copy linkTweet thisAlerts:
@the_treeMar 30.2005 — It could be IE trying to tell you something such as that it can remember an e-mail adress for your email field. I can't think what else, sorry.
Copy linkTweet thisAlerts:
@martonicauthorMar 30.2005 — It could be IE trying to tell you something such as that it can remember an e-mail adress for your email field. I can't think what else, sorry.[/QUOTE]

Thanks but that's not it - this effect comes up in pages where nothing has ever been entered.

Are all your <input> fields yellow under IE - or has anyone else noticed something strange going on, with some fields white for no apparent reason?

Thanks for any help you can provide.
Copy linkTweet thisAlerts:
@ray326Mar 30.2005 — Got link?
Copy linkTweet thisAlerts:
@hcclnoodlesMay 04.2005 — I am getting the same problem and have 6.0.2900 aswell, infact i get it on every PC i use (not sure if they are all the same version though)

exactly the same though, really basic web page with 4 input boxes, 2 yellow and 2 white....what the hell is it all about ??? It looks awful
Copy linkTweet thisAlerts:
@hcclnoodlesMay 04.2005 — its ok, found the answer its the google toolbar autofill option, sorry for the post
×

Success!

Help @martonic spread the word by sharing this article on Twitter...

Tweet This
Sign in
Forgot password?
Sign in with TwitchSign in with GithubCreate Account
about: ({
version: 0.1.9 BETA 3.3,
whats_new: community page,
up_next: more Davinci•003 tasks,
coming_soon: events calendar,
social: @webDeveloperHQ
});

legal: ({
terms: of use,
privacy: policy
});
changelog: (
version: 0.1.9,
notes: added community page

version: 0.1.8,
notes: added Davinci•003

version: 0.1.7,
notes: upvote answers to bounties

version: 0.1.6,
notes: article editor refresh
)...
recent_tips: (
tipper: @darkwebsites540,
tipped: article
amount: 10 SATS,

tipper: @Samric24,
tipped: article
amount: 1000 SATS,

tipper: Anonymous,
tipped: article
amount: 10 SATS,
)...